Top.Mail.Ru
Уведомления
Очистить все

[Решено] Нестабильно работает плата с STM32. Проблема с BOOT?

Payne
(@payne)
Level 1

Добрый день, вытравил свою платку небольшую для тестов, но ошибся при разводке, забыл BOOT0 подтянуть к земле резистором. Сейчас плата работает, прошиваю через ST-Link, родным загрузчиком (System Bootloader) не пользуюсь. Все ок, но иногда плата после перезапуска не заводится, нужно перезапустить еще раз, тогда всегда все нормально. Вопрос такой - может это быть связано как раз с тем, что BOOT0 не подтянул?

Цитата
Topic starter Размещено : 23.03.2022 13:41
Raf
 Raf
(@raf)
Level 4

BOOT0 просто в воздухе висит?

ОтветитьЦитата
Размещено : 23.03.2022 14:18
Эдуард
(@eduard)
Level 2 Moderator

Если висит в воздухе. Повесьте соплю на землю.

Резистор ставят, что бы оставлять возможность программировать. Если не нужна, можно сразу на землю.

ОтветитьЦитата
Размещено : 23.03.2022 18:47
Payne
(@payne)
Level 1
От: @raf

BOOT0 просто в воздухе висит?

Да...

 

ОтветитьЦитата
Topic starter Размещено : 23.03.2022 18:59
Payne
(@payne)
Level 1
От: @eduard

Если висит в воздухе. Повесьте соплю на землю.

Резистор ставят, что бы оставлять возможность программировать. Если не нужна, можно сразу на землю.

Эх понятно, спасибо, попробую подпаять для проверки проводом к земле.

 

ОтветитьЦитата
Topic starter Размещено : 23.03.2022 19:00
Raf
 Raf
(@raf)
Level 4

@payne 

Отпишитесь о результатах )

ОтветитьЦитата
Размещено : 23.03.2022 20:25
Payne
(@payne)
Level 1

Все подтвердилось, BOOT0 подтянул к земле, проблема ушла. Теперь буду платки переделывать что ж поделать.

ОтветитьЦитата
Topic starter Размещено : 24.03.2022 09:16
Raf
 Raf
(@raf)
Level 4

@payne Ну ничего, всякое бывает, хорошо что проблема выявилась на этапе отладки.

ОтветитьЦитата
Размещено : 24.03.2022 11:26
Payne
(@payne)
Level 1

@raf 

Да уж, спасибо еще раз за консультацию!

ОтветитьЦитата
Topic starter Размещено : 26.03.2022 17:28
Поделиться: