Top.Mail.Ru
Уведомления
Очистить все

[Решено] Сообщения Error Log в окне STM32CubeIDE, Помогите разобраться в сообщениях

Страница 2 / 3
Aveal
(@aveal)
Illustrious Member Admin

@peotr плюс антивирус, брандмауэр отключать и пробовать. Это личный ПК или корпоративный в корпоративной же сети?

ОтветитьЦитата
Размещено : 18.11.2021 13:38
Aveal
(@aveal)
Illustrious Member Admin

В Available Sites - каждый по отдельности reload.

ОтветитьЦитата
Размещено : 18.11.2021 13:40
Peotr
(@peotr)
Eminent Member

@aveal со всеми "галочками". Всё равно "выбивает".

ПК личный.

ОтветитьЦитата
Topic starter Размещено : 18.11.2021 14:17
Peotr
(@peotr)
Eminent Member

@aveal нашёл одну непонятку. Если при запуске программы в окне Workspace указать путь по умолчанию, не важно, что там нет моих скетчей, никаких "бяк" не появляется, всё работает "на ура"! Если в этом окне указать путь, где находится нужный скетч, появляются "бяки", о которых я и открыл эту тему. У меня на диске С маловато места, и я нагружаю более свободный D. Наверное, где-то в настройках нужно подправить адреса, я перелопатил все настройки, ничего похожего не нашёл. А что об этом думают профи? STM32CubeIDE установил на D, Репозиторий там же, путь к Репозиторию в настройках указал.

ОтветитьЦитата
Topic starter Размещено : 18.11.2021 15:21
Aveal
(@aveal)
Illustrious Member Admin

@peotr хмм, может все-таки проблема с самим проектом связана тогда? Если пустой проект создать по измененному пути? У меня не вылезли ошибки с разными путями.

ОтветитьЦитата
Размещено : 18.11.2021 15:29
Peotr
(@peotr)
Eminent Member

@aveal Да у меня с десяток проектов. Везде одно и то же. И, как я писал, если из программы удалить ВСЕ проекты, будет то же самое. Зато, если при запуске указать путь "по умолчанию", потом запускаю любой проект, и всё нормально. Что-то, наверное, с какими-нибудь служебными файлами, типа workspace_1.7.0, .metadata, я думаю...

ОтветитьЦитата
Topic starter Размещено : 18.11.2021 15:35
Peotr
(@peotr)
Eminent Member

 

4

 

4

@aveal

1
2
ОтветитьЦитата
Topic starter Размещено : 18.11.2021 15:41
Peotr
(@peotr)
Eminent Member

Не получилось отредактировать, не смог загрузить один рисунок:

3

 

ОтветитьЦитата
Topic starter Размещено : 18.11.2021 15:50
Peotr
(@peotr)
Eminent Member

@aveal чёрт его знает, добавил в свой злополучный директорий папку workspace_1.7.0, и по этому пути всё запускается нормально. Т.е. по пути D:\STM32\STM32_File запускается с ошибками, а по пути D:\STM32\STM32_File\workspace_1.7.0 нормально. Думаю, дело не в имени, наверное, при создании новой папки, по сути, нового пути, происходят какие-то важные установки. В этом вся соль...

ОтветитьЦитата
Topic starter Размещено : 18.11.2021 16:10
Aveal
(@aveal)
Illustrious Member Admin

@peotr а в проблемном D:\STM32\STM32_File нет файлов от других wordspace'ов?

ОтветитьЦитата
Размещено : 18.11.2021 17:52
Peotr
(@peotr)
Eminent Member

Моё чутьё не подвело! Для начала я просто удалил все скетчи из файловой папки. Как и ожидал, НЕ ПОМОГЛО! Тогда я вернул все скетчи на место, и удалил папку .metadata. При повторном открытии программы были сделаны какие-то настройки, и всё стало ХОРОШО!

Если кто Вас будет мучить с подобными вопросами, рекомендуйте им обновить папку .metadata через удаление!

Спасибо за помощь, Вы планомерно направляли меня в нужное русло.

Но как меня достало постоянное выбивание из аккаунта!.. 🙁

ОтветитьЦитата
Topic starter Размещено : 18.11.2021 18:14
Aveal
(@aveal)
Illustrious Member Admin

@peotr спасибо за информацию!

Пока не смог найти хоть какую-то потенциальную причину выбивания... В браузере куки не удаляются слишком часто?

ОтветитьЦитата
Размещено : 18.11.2021 18:56
Peotr
(@peotr)
Eminent Member

@aveal Нет, конечно. Я же вхожу в почту, на другие форумы, в магазины по кукам, и нигде подобное не встречалось. Я работаю в основном в Мозилле. Можно попробовать другой браузер. Сейчас попробую.

ОтветитьЦитата
Topic starter Размещено : 18.11.2021 19:38
Peotr
(@peotr)
Eminent Member

@aveal Попробовал в Хроме, та же хрень. Плохо ещё и то, что после входа выходишь из форума, приходится потом, после входа, опять искать нужную страницу форума. Неужели такое только у меня? Да, после выхода логин и пароль сохраняются в окнах. Это касательно куков. Хоть повторно набирать не приходится.

ОтветитьЦитата
Topic starter Размещено : 18.11.2021 20:14
Aveal
(@aveal)
Illustrious Member Admin

Мыслишка небольшая появилась, если есть возможность, проверь плз сейчас - не изменилась ли ситуация. Заранее спасибо!

ОтветитьЦитата
Размещено : 18.11.2021 20:50
Страница 2 / 3
Поделиться: